Frontend Tech + >> MAMEUI & IV/Play
View all threads Index   Threaded Mode Threaded  

Pages: 1

roblipsett
MAME Fan
Reged: 01/28/14
Posts: 5
Send PM


light guns in mameui32 152
#323122 - 03/10/14 04:16 AM


I have a machine that is running on windows xp I have actlabs light guns and also ems topgun original version. the act lab guns work great on the old version 109 i had. I am trying to upgrade to mameui32 version 152. I have tried all different configurations of mame.ini wheare as I have mouse enabled mouse disabled light guns set as light gun and also as mouse. lightguns turned on and also off along with multiple light guns on and off. I can not get mame to recognize the lightguns. I go to in game choose button 1 press enter and pull the trigger. the game does not except the trigger pull but as I am looking at the screen I can move the highlight bar up and down by pointing the gun and pulling the trigger but the game itself does not see the guns. has mame technology progressed past the point where it can see these guns and this old technolgy will not work or am I doing something majorly wrong????



TafoidAdministrator
I keep on testing.. testing.. testing... into the future!
Reged: 04/19/06
Posts: 2922
Loc: USA
Send PM


Re: light guns in mameui32 152 new [Re: roblipsett]
#323124 - 03/10/14 04:20 AM


> I have a machine that is running on windows xp I have actlabs light guns and also ems
> topgun original version. the act lab guns work great on the old version 109 i had. I
> am trying to upgrade to mameui32 version 152. I have tried all different
> configurations of mame.ini wheare as I have mouse enabled mouse disabled light guns
> set as light gun and also as mouse. lightguns turned on and also off along with
> multiple light guns on and off. I can not get mame to recognize the lightguns. I go
> to in game choose button 1 press enter and pull the trigger. the game does not except
> the trigger pull but as I am looking at the screen I can move the highlight bar up
> and down by pointing the gun and pulling the trigger but the game itself does not see
> the guns. has mame technology progressed past the point where it can see these guns
> and this old technolgy will not work or am I doing something majorly wrong????

Many things about inputs changed between those versions. AFAIK, you can get the information at actlabs webstie itself versions later than 0.117.

http://www.act-labs.com/LightGunSetUp/LightGunSetUp.htm



roblipsett
MAME Fan
Reged: 01/28/14
Posts: 5
Send PM


Re: light guns in mameui32 152 new [Re: Tafoid]
#323132 - 03/10/14 01:42 PM


yep I had already been too that gem of a website and that was one of the many different configurations I have tried. the version of mame would not allow me to choose the trigger for the light gun as button one. after choosing a diffent key for button one I tried to choose the x plane in the setup menu but mame did recognize the gun all I could see happening on the screen was a shaded selection bar separate from the one I was using on the menu moving up and down with where I was pointing the gun on the screen so I know the gun was working in windows but invisible to mame as a gun



vicdreyer
MAME Fan
Reged: 10/16/05
Posts: 15
Send PM


Re: light guns in mameui32 152 new [Re: roblipsett]
#323209 - 03/11/14 05:08 PM


If you are using two light guns, you may want to try installing the Aimtrack configuration utility on this site

http://www.ultimarc.com/aimtrak.html

You probably tried this, but make sure your mame.ini has the lightgun enabled (lightgun '1'). The following is taken from my mame.ini

#
# CORE INPUT OPTIONS
#
coin_lockout 1
ctrlr
mouse 1
joystick 1
lightgun 1
multikeyboard 0
multimouse 0
steadykey 0
ui_active 0
offscreen_reload 1
joystick_map auto
joystick_deadzone 0.3
joystick_saturation 0.85
natural 0
joystick_contradictory 0
coin_impulse 0

Aside from that, make sure your lightgun trigger (I.e. Button 1) works on the windows desktop (before you start Mame). Then start Mame to see if the trigger (button 1) is recognized,

Also before doing any of the above, you may want to reset your Mame to it's default (Options-->Reset to Default). then try playing around with the settings.



what2be
MAME Fan
Reged: 07/25/04
Posts: 13
Loc: Eureka, CA
Send PM


Re: light guns in mameui32 152 new [Re: vicdreyer]
#327022 - 06/16/14 12:38 AM


This is my Tutorial for .153 and the Ultimarc AimTrak lightguns.
Mame 0.153 & Aimtrak Configuration

If your Aimtrak gun isn’t calibrated yet do the standard calibration by standing back at least 2 ft from your monitor and pointing the gun down and holding the trigger for 5 seconds. You should see the mouse cursor go to the top left of the screen and flash. Aim at it and shoot it, if you did it correctly the mouse cursor will then go to the top right corner of the screen. If it doesent, shoot it again until it does move to the top right corner of the screen. Now shoot it again, and then when it moves to the bottom center of the screen shoot it one last time.

=================================================================================

Now, open up your web browser and download the latest Ultimarc Aim Trak utility currently (1.9) here: (The link is located about halfway down the page.)

DISREGARD ANY INSTRUCTIONS ON THE ULTIMARC WEBPAGE. JUST DOWNLOAD THE UTILITY

http://ultimarc.com/aimtrak.html

Start the utility and make sure it says device 1 and shows the firmware version currently (8.15)

Now,under the configuration tab, make sure you setup the button assignments as follows:

---------On Screen----------Off Screen
TRIG = Mouse LEFT-------Mouse RIGHT
AUX= ----------------------AUX= --------
P1= GP Button 1----------GP Button2
P2= GP Button 3----------GP Button4

Keep the Enable Cal box’s checked for both ON and OFF screen for TRIG, P1, and P2
Under Cal Delay set it at 60 (this is so when your playing games that have continuous fire by holding down the trigger you dont go into calibration mode.)

Make sure the Emulate Mouse circle is checked and then click on “Apply Changes”
Exit the utility.

=================================================================================

Mame 0.153 configuration
NOTE: I am using mameui64.exe and my mame.ini is located in my \mameui64\ini folder. Do not get step 2 below confused with the mameui64.ini that is located where you have your mameui64.exe located.

Go to the mame.ini and change your settings so they match the ones below. The section your looking for is titled “Core Input Options” Change your settings so they match the ones below.
ctrlr
mouse 0
joystick 1
lightgun 0
multikeyboard 0
multimouse 1
steadykey 0
ui_active 0
offscreen_reload 1

If you are using multiple keyboards you can change that value if you like but the Mouse, Joystick, Lightgun, Multimouse and Offscreen reload MUST be just like above.

Now go down a few more lines in the in the INI until you find this:

paddle_device mouse
adstick_device keyboard
pedal_device keyboard
dial_device mouse
trackball_device keyboard
lightgun_device lightgun
positional_device keyboard
mouse_device mouse

It doesent matter what any of these say EXCEPT these 2:

lightgun device lightgun
mouse device mouse

It needs to be set like this for it to work with games needing offscreen reloads as well as games requiring a second button assignment. (Ie, for grenades or such in games like Beast Buster)

================================================

Run mame and start any game you like.
After the game loads, Hit the TAB key and pick ”Input General” and then “Player 1 Controls”

Move down until the “P1 Button 1” highlighted. DO NOT PRESS ENTER!!
BEFORE you press enter, point the lightgun steadily at the screen and THEN press enter, and without moving the gun, pull the trigger.
It should say “Gun x B0” (where x could be 1 , 2, 3 etc.)

Move down one line until “P1 Button 2 is highlighted. DO NOT PRESS ENTER!!
BEFORE you press enter, again point the lightgun steadily at the screen and THEN press enter, and without moving the gun, push the button on the right side of the gun. It should say “Joy x B0” (where x could be 1 , 2, 3 etc.)

Move WAY down the list until you see “Lightgun X Analog Dec” Press “Enter” and then the “ESC” Key.
It should now say “NONE”. Do the same thing for “Lightgun X Analog Inc” and as well as for “Lightgun Y Analog Dec” and “Lightgun Analog Y Inc”.

Now go back up until “Lightgun Analog X” is highlighted. DO NOT PRESS ENTER!!
BEFORE you press enter, point the lightgun steadily at the center of the screen and THEN press enter, and move the gun slowly to the right until it says “Gun x X” (where x could be 1, 2, 3)

Now scroll down until “Lightgun Analog Y” is highlighted. DO NOT PRESS ENTER!!
BEFORE you press enter, point the lightgun steadily at the center of the screen and THEN press enter, and move the gun slowly to the left until it says “Gun x Y” (where x could be 1, 2, 3)

Scroll down until “Return to Previous Menu” is highlighted and then press enter, and again on the next screen. Now go start any lightgun game and it should work perfectly.

( I tested mine on Area 51 Maximum force and then on Beast Busters so I know those 2 work fine)

If you have any problems or suggestions feel free to post them.



kusunagix
MAME Fan
Reged: 04/18/15
Posts: 2
Send PM


Re: light guns in mameui32 152 new [Re: what2be]
#339051 - 04/18/15 02:41 AM


Hi there
Excellent post!, got my first gun working perfectly but how does one get both guns working?

Im finding in mame that both guns axis are recognised as "GUN 1" so they both move together. I believe they should be GUN 1 and GUN 2 or have different ID's

From the hardware config end i have made sure they are using a different ID.

The buttons are fine as im using key remapping.

Have I missed something?

Im using MAME UI64 149 No Nag but have tried 153 and 154 with the same result.

Mame config shows dual light guns as greyed out.
Right down the bottom of the mame.ini i see the ref to this and if i set to 1 then neither gun works but hitting esc a few times on player 2 lightgun x and y shows gun2 but i cant do anything with either gun still.

Please can you help?
Your assistance greatly appreciated!



vicdreyer
MAME Fan
Reged: 10/16/05
Posts: 15
Send PM


Re: light guns in mameui32 152 new [Re: kusunagix]
#339174 - 04/21/15 09:42 PM


> Hi there
> Excellent post!, got my first gun working perfectly but how does one get both guns
> working?
>


In order to have Mame recognize two guns, you need to first set up and configure the Aimtrak utility to show two guns (two devices) before you begin Mame. The detailed setup guide here:
http://ultimarc.com/AimTrak%20Setup%20Guide.pdf

explains how to set up two light guns.

From there, start Mame, start a game, go into the setup for that game(F2) and you should be able to configure the separate gun settings for Player 1 and Player 2.

Edited by vicdreyer (04/21/15 09:49 PM)



Braveheart
MAME Fan
Reged: 05/03/15
Posts: 4
Send PM


Re: light guns in mameui32 152 new [Re: vicdreyer]
#339576 - 05/03/15 07:06 PM


Hi,
I have the exact same problem, I just got two aimtrak gun and I am trying to make the second player work with the second gun. If i am playing with one gun it work fine, but I doing anything and I can't fine a way to make work the second gun for the second player. I am on Windows 8.1 with mame .159. I have the same mame config from the .153 tutorial of this thread :

mouse 0
joystick 1
lightgun 0
multikeyboard 0
multimouse 1
steadykey 0
ui_active 0
offscreen_reload 1

paddle_device mouse
adstick_device keyboard
pedal_device keyboard
dial_device mouse
trackball_device keyboard
lightgun_device lightgun
positional_device keyboard
mouse_device mouse

I have the aimtrak utility and my first gun have ID 4 and my second gun have ID 5 and both trigger working in windows and they are both well calibrate as explained in the instruction manuel from aimtrak website.

When I go in mame and I try for exemple Area-51 Maximum force or Operation Wolf 3, my two gun are seen as 2 blue target that I can move separatly with each gun. If I hit TAB and go in player one and player 2 config for Button 1 and I hit trigger button of my guns, each gun are seen as GUN 1, it think that my two gun are the same gun. If I hit F2, I can do the test for both gun, and I can start game for both player, each player is able to move the target, but if a player hit the trigger, it fire for both player at the same time.

Is I am doing something wrong, or I need a different config for mame .159 or it's a problem with the aimtrak gun and Windows 8.1?

Thanks you in advance!



vicdreyer
MAME Fan
Reged: 10/16/05
Posts: 15
Send PM


Re: light guns in mameui32 152 new [Re: Braveheart]
#339615 - 05/04/15 03:11 PM


> Hi,
> I have the exact same problem, I just got two aimtrak gun and I am trying to make
> the second player work with the second gun. If i am playing with one gun it work
> fine, but I doing anything and I can't fine a way to make work the second gun for the
> second player. I am on Windows 8.1 with mame .159. I have the same mame config from
> the .153 tutorial of this thread :
>
> mouse 0
> joystick 1
> lightgun 0
> multikeyboard 0
> multimouse 1
> steadykey 0
> ui_active 0
> offscreen_reload 1
>
> paddle_device mouse
> adstick_device keyboard
> pedal_device keyboard
> dial_device mouse
> trackball_device keyboard
> lightgun_device lightgun
> positional_device keyboard
> mouse_device mouse
>

your mouse and lightgun in your config (mame.ini) should be set to 1 (not 0)

once you set that, restart Mame and try to setup Player 1 and Player 2



kusunagix
MAME Fan
Reged: 04/18/15
Posts: 2
Send PM


Re: light guns in mameui32 152 new [Re: vicdreyer]
#339620 - 05/04/15 05:11 PM


Hi thanks for your responses but now i have turned mouse on i get mouse x and mouse y for both guns instead of gun1 for both.

Still have the same issue where both guns are seen as the same when they are definitely on different id's as per your guide.

Im using LCD TOPGUN 3's which are very similar to Aimtrack in the way they work and have a flick switch on each gun and wireless dongle for channel 1 and 2 to be able to set different id's so that each gun is seperate device.

I have read something about making sure you have raw input enabled and not direct input in mame as it cant differentiate between multiple devices but no idea where i go in mame for this?
http://forum.arcadecontrols.com/index.php?topic=109956.0



Braveheart
MAME Fan
Reged: 05/03/15
Posts: 4
Send PM


Re: light guns in mameui32 152 new [Re: vicdreyer]
#339621 - 05/04/15 06:55 PM


Yes I already tried to put these two to 1 and it do the same thing, both gun are seen as Gun 1 and Mouse 1 Button 0 for the trigger



vicdreyer
MAME Fan
Reged: 10/16/05
Posts: 15
Send PM


Re: light guns in mameui32 152 new [Re: kusunagix]
#339653 - 05/05/15 03:50 PM


> Hi thanks for your responses but now i have turned mouse on i get mouse x and mouse y
> for both guns instead of gun1 for both.
>

Just to be sure that Mame recognizes both guns, try this and tell me what happens:

1. Connect both guns.
2. Start Mame and start one of the gun games (i.e. Area 51)
3. Press OK or Enter (or move joystick left and right) to get to main game screen.
4. Hit TAB (to enter setup)
5. Select 'Input (this game)'
6. Scroll down and select 'P1 Button 1' (Player 1) Press Enter (keyboard), then pull trigger on 1st gun. After you pull the trigger, it should read 'Gun X BO' (where X = 1,2,3, etc)
7. Scroll down to 'P2 Button 1' (Player 2) Press Enter (keyboard), then pull trigger on 2nd gun. After you pull trigger, it should say 'Gun X BO' (where x = 1,2,3, etc) but SHOULD be different from 1st gun. For example, the first gun trigger button could be 'Gun 2 BO' and the second gun be 'Gun 3 BO'
If you get two different readings (i.e. 'Gun 2 BO' and 'Gun 3 BO') then Mame recognizes two different triggers.
If you get two SAME readings (i.e. Gun 2 BO' and 'Gun 2 BO' then Mame only sees one trigger.

If Mame sees two different triggers, then you can go ahead and adjust the movement settings for each gun (Lightgun X Analog, Lightgun Y Analog for first gun, Lightgun X2 Analog, Lightgun Y2 Analog for second gun).

Let me know if this works.



Braveheart
MAME Fan
Reged: 05/03/15
Posts: 4
Send PM


Re: light guns in mameui32 152 new [Re: vicdreyer]
#339657 - 05/06/15 02:00 AM


Yes, I already did all of this, but what I said is exactly your second case that mame see only one trigger, both are GUN 1 BO. Same reading for both guns. GUN 1 BO and GUN 1 BO, mame only see one trigger.



vicdreyer
MAME Fan
Reged: 10/16/05
Posts: 15
Send PM


Re: light guns in mameui32 152 new [Re: Braveheart]
#339659 - 05/06/15 03:35 AM


> Yes, I already did all of this, but what I said is exactly your second case that mame
> see only one trigger, both are GUN 1 BO. Same reading for both guns. GUN 1 BO and GUN
> 1 BO, mame only see one trigger.

You already may have tried this, but are your guns connected to separate USB ports? If so, does the Aimtrak utility show two different device ID's? If so, try deleting your Mame.ini before starting mame (this will reset Mame to the default configuration) and then go into setup and try again.



Braveheart
MAME Fan
Reged: 05/03/15
Posts: 4
Send PM


Re: light guns in mameui32 152 new [Re: vicdreyer]
#339660 - 05/06/15 04:04 AM


Yes my gun are plugued into separate USB ports. In the Aimtrack utility one gun is ID 4, and other one is ID 5. I will try delete Mame.ini...



vicdreyer
MAME Fan
Reged: 10/16/05
Posts: 15
Send PM


Re: light guns in mameui32 152 new [Re: Braveheart]
#339674 - 05/06/15 05:00 PM


> Yes my gun are plugued into separate USB ports. In the Aimtrack utility one gun is ID
> 4, and other one is ID 5. I will try delete Mame.ini...

Hmm, I'm running out of ideas...but one last advice would be to set up the guns in the actual game setup (not the mame setup, but the games internal setup).
For Area 51, after you press ENTER to bypass the first screen, hit F2 to enter the games setup. After a few seconds, you'll see (or should see) the memory test. Hit 2 repeatedly until you get to the main set up screen. (If you hit '2' once too many, press '1' to back out to the main setup page). Press 1 to scroll through the options, highlight Gun Test and press 2 to select. Follow the prompts to set up your gun(s). Hit 1 when done to return to the main setup page.
Press F2 to exit the game setup.
Other than that, I'm out of ideas
Good Luck


Pages: 1

Frontend Tech + >> MAMEUI & IV/Play
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  John IV 
0 registered and 6 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 9186