MAMEWorld Central >> EmuChat
View all threads Index   Threaded Mode Threaded  

Pages: 1

DHispanic
MAME Fan
Reged: 09/27/17
Posts: 3
Send PM


MAME crash caused by Creative Soundblaster X AE-5
#369929 - 09/27/17 05:34 PM


I wanted to check to see if there is some modification for MAME with the new Soundblaster X AE-5.

Mame and MameUI64 kept crashing on startup. I spent last night troubleshooting the issue. I thought it was my video card, but reinstalling the drivers did not help.

I finally found the problem. The Soundblaster can be set up to 32bit 384000hz (studio quality) in Windows 10 sound settings. If it is set to this setting, both Mame and MameUI64 will not startup and will crash. It will, however, work at 32bit 192000hz (studio quality).

Is there a setting within Mame/MameUI64 to fix this issue without having to reset the audio quality?

Thank you, folks!

DH



abelenki
Super Drunk
Reged: 10/20/03
Posts: 898
Loc: Perm, Russia
Send PM


Re: MAME crash caused by Creative Soundblaster X AE-5 new [Re: DHispanic]
#369961 - 09/28/17 04:49 AM


> I wanted to check to see if there is some modification for MAME with the new
> Soundblaster X AE-5.
>
> Mame and MameUI64 kept crashing on startup. I spent last night troubleshooting the
> issue. I thought it was my video card, but reinstalling the drivers did not help.
>
> I finally found the problem. The Soundblaster can be set up to 32bit 384000hz (studio
> quality) in Windows 10 sound settings. If it is set to this setting, both Mame and
> MameUI64 will not startup and will crash. It will, however, work at 32bit 192000hz
> (studio quality).
>
> Is there a setting within Mame/MameUI64 to fix this issue without having to reset the
> audio quality?

try setting this option in mame.ini:

samplerate 384000



MAME Stuff | MAME favorites | Bubble Bobble Series chart / wiki | PC configuration



DHispanic
MAME Fan
Reged: 09/27/17
Posts: 3
Send PM


Re: MAME crash caused by Creative Soundblaster X AE-5 new [Re: abelenki]
#369967 - 09/28/17 11:25 AM


Thank you for the reply. I tried to put that in the ini file, unfortunately , it didn't work. I didn't see any audio configuration information in the ini file.. I added it anyway, no dice.

Is there another file that contains the audio information?



Dullaron
Diablo III - Dunard #1884
Reged: 07/22/05
Posts: 5457
Loc: Fort Worth, Tx
Send PM


Re: MAME crash caused by Creative Soundblaster X AE-5 new [Re: DHispanic]
#369969 - 09/28/17 12:03 PM


> Thank you for the reply. I tried to put that in the ini file, unfortunately , it
> didn't work. I didn't see any audio configuration information in the ini file.. I
> added it anyway, no dice.
>
> Is there another file that contains the audio information?

These are showing in my mame.ini file.

#
# CORE SOUND OPTIONS
#
samplerate 384000 # Lower to this. Or use the one that you tried. 192000 Using the default setting on mine.
samples 1
volume 0

#
# OSD SOUND OPTIONS
#
sound dsound # Change to this.
audio_latency 2

Try this before getting the MAME from this website.

2nd Option. Do this.

Get the newer MAME from http://mamedev.org/release.php and then try again.

I don't trust that one you have. Sound like a modified version of MAME. Might been strip down hack version to where the options are missing.



Windows 10 Pro 64-bit / Intel Core i5-4460 3.20 GHz / 8.00 GB RAM / AMD Radeon R9 200 Series
http://us.battle.net/d3/en/profile/Dunard-1884/
https://sites.google.com/site/o0kinghanco0o/mame_building_info (Updated on the 07/18/2017 at 9:49 PM.)



CiroConsentino
Frontend freak!
Reged: 09/21/03
Posts: 5345
Loc: Brazil
Send PM


Re: MAME crash caused by Creative Soundblaster X AE-5 new [Re: DHispanic]
#369973 - 09/28/17 01:36 PM


New SB card ? ... They say it supports HD audio and yet they still have the audacity to not include a HDMI output for proper HD audio support.
You cannot have HD audio thru optical output



Emu Loader
Ciro Alfredo Consentino
home: http://emuloader.mameworld.info
EmuCon Home: http://emuloader.mameworld.info/emucon
MCM Plus: http://mcm.mameworld.info
e-mail: emuloader@gmail.com



Haze
Reged: 09/23/03
Posts: 4348
Send PM


Re: MAME crash caused by Creative Soundblaster X AE-5 new [Re: CiroConsentino]
#369975 - 09/28/17 07:14 PM


> New SB card ? ... They say it supports HD audio and yet they still have the audacity
> to not include a HDMI output for proper HD audio support.
> You cannot have HD audio thru optical output

most dedicated HD audio solutions I've seen people with are optical..

can't actually remember seeing a non-video device with HDMI in either, nor one that would accept HDMI audio on one input and HDMI video on another to split later.

maybe they exist, but the solution here seems by far the most common



DHispanic
MAME Fan
Reged: 09/27/17
Posts: 3
Send PM


Re: MAME crash caused by Creative Soundblaster X AE-5 new [Re: CiroConsentino]
#369978 - 09/28/17 10:46 PM


Thanks, Dullaron.

I installed the new 0.190 and it had the correct sound options. Unfortunately, I tried setting the audio from 48000 to 384000hz, and it still crashed. I'm guessing since most of the games are 48k sample rate, the program cant handle 384k. Well, at least I can get it to work by lowering the setting in Win 10. Thanks, guys for all your help.




> New SB card ? ... They say it supports HD audio and yet they still have the audacity
> to not include a HDMI output for proper HD audio support.
> You cannot have HD audio thru optical output

HDMI is audio and video in one cable. The HDMI audio output in my 1080Ti is 16bit 48000hz (standard DVD quality). The SBX AE-5 is strickly sound only. It's 32bit, 384000hz. That is the same sound you get in a recording studio. You won't hear the difference in the games on MAME, but for high quality, lossless audio, it's a huge difference. Just need a good set of speakers.


Pages: 1

MAMEWorld Central >> EmuChat
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 27 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 317