MAMEWorld >> Programming
View all threads Index   Threaded Mode Threaded  

Pages: 1

Llaffer
MAME Fan
Reged: 05/04/11
Posts: 171
Send PM


Problems compiling 32-bit MAME 0.179
#359952 - 10/26/16 08:06 PM


I have the source downloaded from mamedev.org and was able to compile the 64-bit version just fine. Though I did have to give it -j1 instead of my normal -j3 to do it. When compiled with -j3, it crashed the compiler.

Compiler is updated to latest version.

When compiling the 32-bit version, I'm using this make command:


Code:

make -j1 PTR64=0 STRIP_SYMBOLS=1



And the compile fails with:


Code:

Compiling src/frontend/mame/ui/viewgfx.cpp...
Compiling src/frontend/mame/ui/widgets.cpp...
Archiving libfrontend.a...
Compiling src/mame/drivers/fm7.cpp...
cc1plus.exe: error: one or more PCH files were found, but they were invalid
cc1plus.exe: error: use -Winvalid-pch for more information
cc1plus.exe: fatal error: ../../../../mingw-gcc/obj/x32/Release/emu.h: No such file or directory
compilation terminated.
fujitsu.make:300: recipe for target '../../../../mingw-gcc/obj/x32/Release/src/mame/drivers/fm7.o' failed
make[2]: *** [../../../../mingw-gcc/obj/x32/Release/src/mame/drivers/fm7.o] Error 1
makefile:544: recipe for target 'fujitsu' failed
make[1]: *** [fujitsu] Error 2
makefile:971: recipe for target 'windows_x86' failed
make: *** [windows_x86] Error 2



Any thoughts? I'll attempt to compile the UI versions at this point and go back to this if there are suggestions.

Thanks.



TafoidAdministrator
I keep on testing.. testing.. testing... into the future!
Reged: 04/19/06
Posts: 2952
Loc: USA
Send PM


Re: Problems compiling 32-bit MAME 0.179 new [Re: Llaffer]
#359962 - 10/27/16 02:43 AM


> I have the source downloaded from mamedev.org and was able to compile the 64-bit
> version just fine. Though I did have to give it -j1 instead of my normal -j3 to do
> it. When compiled with -j3, it crashed the compiler.
>
> Compiler is updated to latest version.
>
> When compiling the 32-bit version, I'm using this make command:
>
> make -j1 PTR64=0 STRIP_SYMBOLS=1
>
> And the compile fails with:
>
> Compiling src/frontend/mame/ui/viewgfx.cpp...
> Compiling src/frontend/mame/ui/widgets.cpp...
> Archiving libfrontend.a...
> Compiling src/mame/drivers/fm7.cpp...
> cc1plus.exe: error: one or more PCH files were found, but they were invalid
> cc1plus.exe: error: use -Winvalid-pch for more information
> cc1plus.exe: fatal error: ../../../../mingw-gcc/obj/x32/Release/emu.h: No such file
> or directory
> compilation terminated.
> fujitsu.make recipe for target
> '../../../../mingw-gcc/obj/x32/Release/src/mame/drivers/fm7.o' failed
> make[2]: *** [../../../../mingw-gcc/obj/x32/Release/src/mame/drivers/fm7.o] Error 1
> makefile recipe for target 'fujitsu' failed
> make[1]: *** [fujitsu] Error 2
> makefile recipe for target 'windows_x86' failed
> make: *** [windows_x86] Error 2
>
> Any thoughts? I'll attempt to compile the UI versions at this point and go back to
> this if there are suggestions.
>
> Thanks.

Only thing that comes to mind is that you didn't MAKE CLEAN before attempting to compile. Otherwise, I'm unsure how to fix your issue outside of making sure your tools are updated and try again.



Llaffer
MAME Fan
Reged: 05/04/11
Posts: 171
Send PM


Re: Problems compiling 32-bit MAME 0.179 new [Re: Tafoid]
#359968 - 10/27/16 05:10 AM


I thought that I did.

I know it's in my batch file. I'll change my j3's to j1's in the batch file and I'll run it again over night (it's over 2 hours to compile it that way when it does work).



Osso1
Reged: 10/17/04
Posts: 200
Send PM


Re: Problems compiling 32-bit MAME 0.179 new [Re: Llaffer]
#359973 - 10/27/16 07:16 AM


have you got the dual 32-bit/64-bit msys64 package?



Formerly (un)known as hanamichi on the mameworld.info message boards.



Llaffer
MAME Fan
Reged: 05/04/11
Posts: 171
Send PM


Re: Problems compiling 32-bit MAME 0.179 new [Re: Osso1]
#359976 - 10/27/16 02:34 PM


Yes. I've been compiling my own versions of 32-bit MAME/MAMEUI and 64-bit MAME/MAMEUI for years, including when they started using the new toolset late last year/early this year.

I did get the 32-bit MAME to compile this time, maybe it was a case of forgetting to clean when entering commands manually.

Though, the UI compiles still failed. I wasn't able to get them compiled for 0.178, either.


Pages: 1

MAMEWorld >> Programming
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  Pi 
0 registered and 5 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 1347