MAMEWorld Central >> News
View all threads Index   Threaded Mode Threaded  

Pages: 1

Mucci
Lurker
Reged: 10/14/03
Posts: 115
Send PM


CLRMAMEpro 4.033 released
#369393 - 09/03/17 10:20 PM


https://mamedev.emulab.it/clrmamepro

started 20 years ago :-)



John IVModerator
IV/Play, MAME, MAMEUI
Reged: 09/22/03
Posts: 1594
Loc: Snohomish, WA, USA
Send PM


Re: CLRMAMEpro 4.033 released new [Re: Mucci]
#369395 - 09/03/17 11:08 PM


Congrats Roman for maintaining the most useful MAME tool of the last two decades.



john iv
http://www.mameui.info/



B2K24
Evolution is a mystery
Reged: 10/25/10
Posts: 2447
Send PM


Re: CLRMAMEpro 4.033 released new [Re: John IV]
#369396 - 09/03/17 11:49 PM


Thank you Roman for 20 years of updates and support.

CMP merged followed by T7Z is the best combination ever

39.5 GB 11673 Archives and everything neatly organized.

Thanks for everything






Dullaron
Diablo III - Dunard #1884
Reged: 07/22/05
Posts: 5506
Loc: Fort Worth, Tx
Send PM


Getting this server update error. new [Re: Mucci]
#369399 - 09/04/17 01:56 AM Attachment: Untitled.png 11 KB (0 downloads)


I will just download the package and then replace it.

[ATTACHED IMAGE]

Attachment



Windows 10 Pro 64-bit / Intel Core i5-4460 3.20 GHz / 8.00 GB RAM / AMD Radeon R9 200 Series
http://us.battle.net/d3/en/profile/Dunard-1884/
https://sites.google.com/site/o0kinghanco0o/mame_building_info (Updated on the 07/18/2017 at 9:49 PM.)



Renegade
Got No Where Else to Go
Reged: 10/01/03
Posts: 437
Send PM


Re: CLRMAMEpro 4.033 released new [Re: Mucci]
#369401 - 09/04/17 02:49 AM



Thank you Roman for the last 20 yrs and for making my life easier!!

I've used it since almost day one and hope to see you continue for another 20!



Only here to annoy...



URherenow
Reged: 09/21/03
Posts: 3977
Loc: Japan
Send PM


Re: Getting this server update error. new [Re: Dullaron]
#369410 - 09/04/17 05:47 AM


I've been getting that same error on the last version. I don't recall it happening last time I used it (2 Mame releases ago), so I'm inclined to think it's a server issue vice an app issue. Not that I could troubleshoot for another 3 weeks or so anyway...

The system version error comes up on startup and again when loading a profile.

EDIT:
and here's why: Since the homepage is now https, you need to download this update manually. The updater will work again once you have 4.033 installed

Edited by URherenow (09/04/17 05:51 AM)



I will be the last person to die in my lifetime.



Dullaron
Diablo III - Dunard #1884
Reged: 07/22/05
Posts: 5506
Loc: Fort Worth, Tx
Send PM


Re: Getting this server update error. new [Re: URherenow]
#369417 - 09/04/17 08:09 AM


> I've been getting that same error on the last version. I don't recall it happening
> last time I used it (2 Mame releases ago), so I'm inclined to think it's a server
> issue vice an app issue. Not that I could troubleshoot for another 3 weeks or so
> anyway...
>
> The system version error comes up on startup and again when loading a profile.
>
> EDIT:
> and here's why: Since the homepage is now https, you need to download this update
> manually. The updater will work again once you have 4.033 installed

Yep it working after I got the updated files from the website.



Windows 10 Pro 64-bit / Intel Core i5-4460 3.20 GHz / 8.00 GB RAM / AMD Radeon R9 200 Series
http://us.battle.net/d3/en/profile/Dunard-1884/
https://sites.google.com/site/o0kinghanco0o/mame_building_info (Updated on the 07/18/2017 at 9:49 PM.)



Pr3tty F1y
MAME Fan
Reged: 07/18/05
Posts: 327
Send PM


Re: Getting this server update error. new [Re: Dullaron]
#369435 - 09/05/17 02:39 AM


> > I've been getting that same error on the last version. I don't recall it happening
> > last time I used it (2 Mame releases ago), so I'm inclined to think it's a server
> > issue vice an app issue. Not that I could troubleshoot for another 3 weeks or so
> > anyway...
> >
> > The system version error comes up on startup and again when loading a profile.
> >
> > EDIT:
> > and here's why: Since the homepage is now https, you need to download this update
> > manually. The updater will work again once you have 4.033 installed
>
> Yep it working after I got the updated files from the website.

Still getting it here with the 32-bit and 64-bit zip versions. Even with a fresh install.



Roman
Regular
Reged: 09/21/03
Posts: 1501
Send PM


Re: Getting this server update error. new [Re: Pr3tty F1y]
#369442 - 09/05/17 12:08 PM



- check if update.dll file date is Sep 3rd
- check if version.ini (version64.ini) got https:// before the urls

Edited by Roman (09/05/17 12:22 PM)



Pr3tty F1y
MAME Fan
Reged: 07/18/05
Posts: 327
Send PM


Re: Getting this server update error. new [Re: Roman]
#369454 - 09/05/17 11:28 PM


> - check if update.dll file date is Sep 3rd
> - check if version.ini (version64.ini) got https:// before the urls

Yes to both and still have the error. I even tried to copy version64.ini as version.ini and it still gives me the 'Can't receive version information!' message.

update.dll has a CRC32 file hash of 25D15E43, with a last modified date of 9/3/17@20:32:44, and is 2,108,928 bytes in length.

version64.ini reads as:

[CMPRO SETTINGS]
version = 4.0330
email = clrmamepro@emulab.it
donate = https://mamedev.emulab.it/clrmamepro/index.html#donate
homepage = https://mamedev.emulab.it/clrmamepro
update = https://mamedev.emulab.it/clrmamepro/version



redk9258
Regular
Reged: 09/21/03
Posts: 3954
Loc: Troy, Illinois USA
Send PM


Re: Getting this server update error. new [Re: Pr3tty F1y]
#369456 - 09/06/17 12:18 AM


Me too. Manually updated to 4.033. Updater no longer works for me.



Roman
Regular
Reged: 09/21/03
Posts: 1501
Send PM


Re: Getting this server update error. new [Re: redk9258]
#369468 - 09/06/17 07:33 AM


1) yes, you need to manually update to 4.033
2) after installing 4.033 you should be able to go to About and hit "update" and it will then say that you're up-to-date

so, you get the problem when doing 2)?



redk9258
Regular
Reged: 09/21/03
Posts: 3954
Loc: Troy, Illinois USA
Send PM


Re: Getting this server update error. new [Re: Roman]
#369473 - 09/06/17 12:16 PM Attachment: CMP Update.PNG 91 KB (0 downloads)


Yes. I updated manually to 4.033.
I hit the "About" button...
Update...
Check Now...

Information

Cannot receive version information!

Windows 7 Pro - 64-bit

[ATTACHED IMAGE]

Attachment

Edited by redk9258 (09/06/17 12:18 PM)



Roman
Regular
Reged: 09/21/03
Posts: 1501
Send PM


Re: Getting this server update error. new [Re: redk9258]
#369475 - 09/06/17 02:09 PM


try to open this url in your browser:

https://mamedev.emulab.it/clrmamepro/version

and check if this is listed under update in your version(64).ini file



Qun Mang
Legend of Link
Reged: 12/12/03
Posts: 639
Loc: Somewhere Outside Hyrule
Send PM


Re: Getting this server update error. new [Re: Roman]
#369476 - 09/06/17 03:52 PM


I've never used the auto update feature, but I tried today and got the same error. Same version- 64-bit. I did a little digging after this post and saw there was a version64.ini in the folder that had been properly updated and contained the correct https: urls:

[CMPRO SETTINGS]
version = 4.0330
email = clrmamepro@emulab.it
donate = https://mamedev.emulab.it/clrmamepro/index.html#donate
homepage = https://mamedev.emulab.it/clrmamepro
update = https://mamedev.emulab.it/clrmamepro/version

However, there was also an old version.ini, presumably from before I used the 64-bit version (dated 2010) that still showed the old information:

[CMPRO SETTINGS]
version = 3.1331
email = clrmamepro@emulab.it
homepage = mamedev.emulab.it/clrmamepro
update = mamedev.emulab.it/clrmamepro/version

I just copied the contents of version64.ini to version.ini and the update button now shows that I am up to date. I then got rid of the version.ini altogether, leaving only version64.ini and updating still works.

Conclusion based on what I see: the 64-bit version of the program still looks for version.ini before version64.ini, and if it finds it will use the information in that file. If version.ini is not present, then it will use version64.ini.



Roman
Regular
Reged: 09/21/03
Posts: 1501
Send PM


Re: Getting this server update error. new [Re: Qun Mang]
#369481 - 09/06/17 06:27 PM


erm......no it does not check version.ini if it's the 64 bit version
but good to know you solved your problem....

it's more likely that it's somehow a caching problem but I doublecheck everything



remax
MAME Fan
Reged: 08/29/12
Posts: 129
Send PM


Re: Getting this server update error. new [Re: Roman]
#369487 - 09/06/17 08:54 PM


> erm......no it does not check version.ini if it's the 64 bit version
> but good to know you solved your problem....
>
> it's more likely that it's somehow a caching problem but I doublecheck everything

erasing the wwwcache file fixed it for me.



Roman
Regular
Reged: 09/21/03
Posts: 1501
Send PM


Re: Getting this server update error. new [Re: remax]
#369488 - 09/06/17 09:04 PM


www cache of what?
cmpro cache folders have nothing to do with it.
I have touched the version file on the server some time ago, Maybe now you get the correct one..... I guess it's more somehow dns/internet related.
I have rechecked the code and it works as expected. and no, a 64bit version does not try to load version.ini and version64.ini :-)

I have tested several machines under several different isps and all work good.



Qun Mang
Legend of Link
Reged: 12/12/03
Posts: 639
Loc: Somewhere Outside Hyrule
Send PM


Re: Getting this server update error. new [Re: Roman]
#369494 - 09/07/17 12:32 AM


> erm......no it does not check version.ini if it's the 64 bit version
> but good to know you solved your problem....
>
> it's more likely that it's somehow a caching problem but I doublecheck everything

The correct reply is "thank you for trying to figure this out, but I can assure you that is not what is happening" or something to that effect. Here's an example from me: thank you for developing this program, releasing it to the public so we may keep up to date with MAME and other programs, and continuing to develop it for all these years.

Now, I was going to say that moving the file back in place caused it to fail again, but as it turns out that was just coincidental as was playing with the files in the first place. In fact, just clicking on "Check Now" button a few times will eventually work even if it fails a few times first. So, you were right- nothing to do with version(64).ini after all.



redk9258
Regular
Reged: 09/21/03
Posts: 3954
Loc: Troy, Illinois USA
Send PM


Re: Getting this server update error. new [Re: Roman]
#369497 - 09/07/17 02:15 AM


> try to open this url in your browser:
>
> https://mamedev.emulab.it/clrmamepro/version

Works fine

> and check if this is listed under update in your version(64).ini file

It is.

Do I need to flush DNS cache here or just wait?



redk9258
Regular
Reged: 09/21/03
Posts: 3954
Loc: Troy, Illinois USA
Send PM


Re: Getting this server update error. new [Re: redk9258]
#369498 - 09/07/17 02:18 AM


Tried "ipconfig /flushdns". No difference. Maybe an ATT problem?



Pr3tty F1y
MAME Fan
Reged: 07/18/05
Posts: 327
Send PM


Re: Getting this server update error. new [Re: redk9258]
#369499 - 09/07/17 02:50 AM


> Tried "ipconfig /flushdns". No difference. Maybe an ATT problem?

I tried to flush my dns and it too did not change anything. I'm using OpenDNS so I'm not sure if it's a DNS issue. I also tried turning off Windows firewall and no change either.



Qun Mang
Legend of Link
Reged: 12/12/03
Posts: 639
Loc: Somewhere Outside Hyrule
Send PM


Re: Getting this server update error. new [Re: Pr3tty F1y]
#369505 - 09/07/17 06:29 AM


Just keep trying- it seems to work sporadically. As I brought up in another post, clicking on the "Check Now" button worked for me about 1 out of 3 or 4 times. Also, I doubt the problem is on our end.


Pages: 1

MAMEWorld Central >> News
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  John IV, Tafoid 
0 registered and 36 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 781