Frontend Tech + >> MAMEUI & IV/Play
Previous thread Previous  View all threads Index   Flat Mode Flat  

trihy
MAME Fan
Reged: 08/29/15
Posts: 3
Send PM
MAMEUI controls settings forgotten bug
08/29/15 11:41 PM


Hi guys, I was experiencing a problem with MAMEUI, after settings all controls to 2 xbox 360 controllers, all went fine, controller works.

But, as soon as I start MAME with one controller and the other one is off, after closing MAMEUI, all controller settings goes back to default.

Only way to avoid this, is always turning on both controllers before opening MAMEUI.


Tried mameuiFX and other mame frontends, and the same bug is present.

Also tried MESS, and the bug is present too.

So, I think it´s a source code bug.

Tried clean windows installs, win7, 8, 10, the bug was replicable in all systems. You just have to configure two controllers and after start mame/mess with just one. Controller settings will reset after next start. Some UI even closes with a "this program stopped working" others just take more time closing, but the problem after next start, is the same in all cases.

The bug can be replicated configuring more controllers. Bug is present as soon as you start mame with one controller off (1 of 2, 3 of 4, etc). Then, the next start, settings cleared.

Edited by trihy (08/29/15 11:44 PM)







Entire thread
Subject Posted by Posted on
* MAMEUI controls settings forgotten bug trihy 08/29/15 11:41 PM
. * Re: MAMEUI controls settings forgotten bug Robbbert  08/30/15 12:47 AM
. * Re: MAMEUI controls settings forgotten bug trihy  08/30/15 07:47 AM
. * Re: MAMEUI controls settings forgotten bug trihy  08/31/15 04:04 PM

Extra information Permissions
Moderator:  John IV 
0 registered and 6 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 2204