MAMEWorld Central >> EmuChat
View all threads Index   Flat Mode Flat  

ElSemi
MAME Fan
Reged: 02/20/07
Posts: 31
Send PM
Re: Is there a known problem with Virtua Racing?
12/20/16 06:54 PM


> > On the Medium course I often encounter something invisible which jolts the car and
> > slows it down. It seems to mostly be in a certain part of the track.
>
> entirely possible
>
> I seem to remember ElSemi had an issue with Sega Rally doing similar and fixed it in
> his emulator, could be those fixes never made it back, or it's a related but slightly
> different bug.
>
> Virtua Racing is also currently using code taken from Daytona instead of it's own,
> because there is currently no method to dump the actual internal code on a VR, that
> could also be causing issues.

Yes, that was caused by wrong float rounding modes, causing the TGP and i960 compute different values. It happened in Daytona, I think in the inner part of the first curve, that there was like an invisible "bump".
What I can't remember is if the issue was in the i960, the TGP or both.







Entire thread
Subject Posted by Posted on
* Is there a known problem with Virtua Racing? hydef 12/19/16 09:05 PM
. * Re: Is there a known problem with Virtua Racing? Haze  12/19/16 09:12 PM
. * Re: Is there a known problem with Virtua Racing? ElSemi  12/20/16 06:54 PM
. * Re: Is there a known problem with Virtua Racing? hydef  12/21/16 12:44 AM

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 22 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 838