MAMEWorld Central >> EmuChat
View all threads Index   Flat Mode Flat  

casm
Cinematronics > *
Reged: 08/27/07
Posts: 646
Send PM
Re: MAME 0.182 only runs once under macOS Sierra (10.12.3)
02/15/17 08:06 PM


> I'm doing active MAME development on my 2013 i7 MacBook Air running Sierra (actually
> the latest developer beta) and I'm having no problems.

Hm. Weird. I'm on a late-2011-era I7 MacBook Pro (8,2) that I've had since, well, late 2011. I've seen build issues on this machine before (usually when I've done something dumb), but never anything like this.

> To clarify: the problem is running multiple games per MAME session (exiting back to
> the built-in front end), or quitting out of MAME and then running it again?

For clarification: I'm not using the built-in UI, just running MAME in single shots from Terminal. Trying to run two games in a row followed by just the binary without any switches would look like the following:


Code:

lolbox:~ casm$ ./mamearcade64 pacman -rompath /path/to/roms/ 
Average speed: 100.00% (13 seconds)
lolbox:~ casm$ ./mamearcade64 rtype -rompath /path/to/roms/
Killed: 9
lolbox:~ casm$ ./mamearcade64
Killed: 9
lolbox:~ casm$



The first run is completely normal; MAME starts up, runs Pac-Man, the game coins up, plays, and I quit it using the ESC key. No problems there.

On the subsequent two runs, the screen is completely black with the OS X pointer on top; at no point does the game start or seem to run blind. The pointer is controllable via the trackpad while this is happening.

However, I cannot exit with ESC as usual and instead have to blindly Force Quit out using CMD-OPTION-ESC on both runs. By "blindly Force Quit out," I mean that the usual Force Quit dialog doesn't pop up - it's a case of hit CMD-OPTION-ESC and wait for the black screen to time out back to the Terminal.

I did do some experimentation with tossing the -window switch onto the commandline and found that the results were pretty much the same: on the first run, everything's fine. On subsequent runs, I just get an all-white window with no indication of anything running and have to do the CMD-OPTION-ESC force quit. However, the standard Force Quit dialog does pop up in this situation.

One other thing I've noticed: if the mamearcade64 binary is moved to a different directory than the one it was last run from, it'll work again - for the first run, anyway, at which point the pattern repeats. In my setup it typically lives in /opt/local/bin, but if I move it to (for example) ~/Desktop/testrun, it will repeat the cycle from that location even if it had failed to run previously from /opt/local/bin.

This behaviour was first noticed when I tried running 0.182 via QMC2 0.71; I reverted to the commandline after that to try tracking down what the cause may be.

Let me know if any of this doesn't make sense and I'll do my best to clarify. FWIW, the only other 64-bit Mac I have sitting around here is an old Core2 Mac Mini (also running 10.12.3); I'll try moving the binary over there later and see what happens.







Entire thread
Subject Posted by Posted on
* MAME 0.182 only runs once under macOS Sierra (10.12.3) casm 01/29/17 03:10 PM
. * But 0.183 looks OK so far [mt] casm  02/28/17 01:36 AM
. * Re: MAME 0.182 only runs once under macOS Sierra (10.12.3) R. Belmont  02/15/17 06:55 PM
. * Re: MAME 0.182 only runs once under macOS Sierra (10.12.3) casm  02/15/17 08:06 PM
. * Late addition: couple of things I forgot [mt] casm  02/15/17 08:22 PM
. * Re: Late addition: couple of things I forgot [mt] R. Belmont  02/15/17 08:34 PM
. * Re: Late addition: couple of things I forgot [mt] casm  02/15/17 08:54 PM
. * Built 0.181 for comparison; got the same result [mt] casm  02/15/17 01:13 AM
. * Re: Just realised something that may be worth mentioning. casm  02/03/17 06:37 AM
. * Re: Now with logfiles [mt] casm  01/29/17 03:54 PM

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 32 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 1081