MAMEWorld >> EmuChat
View all threads Index   Flat Mode Flat  

Reged: 01/07/06
Posts: 836
Send PM
Re: try vs2017
03/10/17 03:31 AM

> > Lets try vs2017 and compile MAME.
> >
> > and a few of these
> > 'Command line error D8040: error creating or communicating with child process'
> >
> > Yeaaaaah, think I am going to go with thats not ready yet.
> Nothing we can do about internal compiler errors, that's almost certainly a bug on
> their side. GCC7 is doing the same thing on Debian.

Oh I know. Didn't expect any changes to happen because of it. Was just kinda of amusing and frustrating at the same time. Just me bitching...

ICE bugs are a bitch. One I dealt with years ago was VC had an issue using tabs vs spaces in a #define. Spaces were 'ok' tabs would crash it out. We just worked around it and said 'whole project spaces no more tabs' and left it at that. Another one it was 2 cr/lfs at a particular spot in the cpp. Moved the methods around and it just worked.

This one looks something to do with template substitution and typedefs. The code looks fine. Just crashes it out. Didnt spend much time on it. Probably could set it into vs2015 mode and it would compile fine.

Entire thread
Subject Posted by Posted on
* try vs2017 lharms 03/09/17 06:59 AM
. * Re: try vs2017 Vas Crabb  03/10/17 12:07 AM
. * Re: try vs2017 lharms  03/10/17 03:31 AM
. * --> EmuChat? [nt] Tomu Breidah  03/09/17 11:52 AM
. * Re: --> EmuChat? [nt] StilettoAdministrator  03/09/17 05:42 PM

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 26 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 1251