MAMEWorld Central >> EmuChat
View all threads Index   Flat Mode Flat  

TServo2049
Lurker
Reged: 11/24/03
Posts: 41
Send PM
Re: Frogger - small bug in MAME
05/22/17 05:18 AM


Very interesting. I looked at every YouTube video of a real arcade machine I could, and every single one matches yours. The official ports/emulations on Genesis, Game Boy Advance, Xbox 360, etc. all have it positioned like yours too. I even found some old YT videos of MAME where it looked correct (and I remembered it looking like your clip of the real machine when I was last following MAME a decade ago). The startup routine with the screen filled with zeroes used to show the blue ended 16 rows down, now it ends 17 rows down.

I previously thought this might have been a regression introduced when cocktail background rotation was fixed in 0.126u1, but I tested in 0.125, and it looks wrong there too. It looked correct in 0.124. I think I've nailed down that it was introduced with the Galaxian driver rewrite that was released in 0.125. That was almost 10 years ago, but nobody seems to have noticed until you did. Nice catch! Hopefully this info will make it to the devs.







Entire thread
Subject Posted by Posted on
* Frogger - small bug in MAME JonBoyRetro 05/22/17 12:09 AM
. * Re: Frogger - small bug in MAME Osso1  05/26/17 11:18 AM
. * Re: Frogger - small bug in MAME Haze  05/26/17 04:11 PM
. * Re: Frogger - small bug in MAME TServo2049  05/26/17 08:59 PM
. * Re: Frogger - small bug in MAME JonBoyRetro  05/30/17 12:37 AM
. * Re: Frogger - small bug in MAME TServo2049  05/22/17 05:18 AM

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 32 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 935