MAMEWorld >> EmuChat
View all threads Index   Flat Mode Flat  

Reged: 06/20/07
Posts: 54
Loc: New Zealand
Send PM
Re: Trouble recording INPs.
12/03/17 10:35 PM

> WolfMAME used to have record and playback INP options in the UI, but 192 doesn't. I
> am doing something wrong trying to create INPs from the command line, because every
> INP I make is only 1 frame long, and 1KB in size. When attempting to playback the
> INP, messages say "inpview invalid type specified", and "input file for machine
> "___empty", not for "Jumpkun"". Every time I start the UI, a message says "error in
> command line: while parsing .\mame.ini: illegal integer value for inpview: "";
> reverting to".
> I have deleted all config files I found, and it still happens. When trying to make
> INPs, I was typing ".\mame64 -rec jumpkun", ".\mame64 -rec jumpkun.INP", .\mame64
> -rec jumpkun jumpkun", and .\mame64 -rec jumpkun jumpkun.INP".

___empty being involved tells me that the UI is appearing at some point. To avoid that you need to provide the driver you're going to record. WolfMAME provides batch files for recording and playback, it is recommended to use these. Syntax is record gamename INP-filename [optional extra switches] It will add the .inp extension for you. If you have Tcl/Tk installed, there is a basic GUI that can be used also.

As for the "error in commandline" sounds like the inpview setting in mame.ini is incorrect (it should be a number, or 0 to disable).

- Barry Rodewald
Editor at MARP -

Entire thread
Subject Posted by Posted on
* Trouble recording INPs. Diet Go Go Fan 12/03/17 09:07 PM
. * Re: Trouble recording INPs. mahlemiut  12/03/17 10:35 PM
. * Re: Trouble recording INPs. Diet Go Go Fan  12/04/17 01:30 AM

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 50 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 377