MAMEWorld >> EmuChat
View all threads Index   Threaded Mode Threaded  

Pages: 1

hydef
Reged: 04/09/16
Posts: 150
Send PM


Is there a known problem with Virtua Racing?
#361441 - 12/19/16 03:05 PM


On the Medium course I often encounter something invisible which jolts the car and slows it down. It seems to mostly be in a certain part of the track.



MAME Artwork / Artwork Previews



Haze
Reged: 09/23/03
Posts: 5069
Send PM


Re: Is there a known problem with Virtua Racing? new [Re: hydef]
#361442 - 12/19/16 03:12 PM


> On the Medium course I often encounter something invisible which jolts the car and
> slows it down. It seems to mostly be in a certain part of the track.

entirely possible

I seem to remember ElSemi had an issue with Sega Rally doing similar and fixed it in his emulator, could be those fixes never made it back, or it's a related but slightly different bug.

Virtua Racing is also currently using code taken from Daytona instead of it's own, because there is currently no method to dump the actual internal code on a VR, that could also be causing issues.



ElSemi
MAME Fan
Reged: 02/20/07
Posts: 34
Send PM


Re: Is there a known problem with Virtua Racing? new [Re: Haze]
#361502 - 12/20/16 12:54 PM


> > On the Medium course I often encounter something invisible which jolts the car and
> > slows it down. It seems to mostly be in a certain part of the track.
>
> entirely possible
>
> I seem to remember ElSemi had an issue with Sega Rally doing similar and fixed it in
> his emulator, could be those fixes never made it back, or it's a related but slightly
> different bug.
>
> Virtua Racing is also currently using code taken from Daytona instead of it's own,
> because there is currently no method to dump the actual internal code on a VR, that
> could also be causing issues.

Yes, that was caused by wrong float rounding modes, causing the TGP and i960 compute different values. It happened in Daytona, I think in the inner part of the first curve, that there was like an invisible "bump".
What I can't remember is if the issue was in the i960, the TGP or both.



hydef
Reged: 04/09/16
Posts: 150
Send PM


Re: Is there a known problem with Virtua Racing? new [Re: ElSemi]
#361512 - 12/20/16 06:44 PM


Thanks for the info.

I haven't played the expert track yet, but if anyone's wondering, I get the ghost bump around this section https://youtu.be/eq7NBEenLjs?t=27s Anywhere between the rock on the left and the checkpoint.



MAME Artwork / Artwork Previews


Pages: 1

MAMEWorld >> EmuChat
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 5 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 1260