MAMEWorld >> Hardware
Previous thread Previous  View all threads Index   Next thread Next   Threaded Mode Threaded  

Pages: 1

Naoki
Reged: 11/10/09
Posts: 1998
Loc: United Kingdom
Send PM


Some questions regarding I/O
#246176 - 02/10/11 02:42 AM


Hi guys.

I got the JST connectors I've been waiting for today nd it got me thinking of controls gain. I'm a little confused how the Sga I/O Board type 1 works. After connecting it to a USB socket I noticed it did nothing, not even light up the LEDs. Fair enough, it has +12 and +5v in ports so I gathered it picks it's juice from them, not the USB connector. Looking at it and how I'll be using a PC power supply with it, I know that aslong as the volatge is right it should work fine yet I'm a little scared when I plug 5v and 12v into it the chip will blow up. Don't know why, but is this even possible?

Also, with Digital Inputs, I read somewhere that they work like a Mega Drive pad, so you send 5V into it when not active and GND when it is. I'm a littl skeptical over this, as it would make more sense for 5V when active. Anyway, I'm not really sure, and even with the Pinout I'm not entirely sur ehow to proceed. Just wire say P1 Start to a switch and the other end at the GND terminal?

And with the 26-pin analogue port (Despite not owning the 26-pin JST RA part), how would one connect a Pot up to it? I looked at the pinout but it confused me.

The only other thing is the JVS Power, which while not related to the I/O still troubles me. Looking at the Pinout from seganaomi.com, I thought I had the power roughyly sorted out. SegaNaomi and the Naomi manual both say:

Quote:


CN1 8Pin JST VL connector
----------------------------
01 NC
02 +3.3V
03 +5V
04 +12V
05 GND
06 GND
07 GND
08 GND

CN2 6Pin JST VL connector
----------------------------
01 NC
02 +3.3V
03 +5V
04 GND
05 GND
06 GND



Yet AndyGeezer's video of his Chihiro confused me.


His power loom seems to say that Pin 3 on the 8-Pin is 12v and 5v is on the 4th pin. This confused me, but is the Manual right and his wiring colours different?

Thanks for any help

EDIT: Oh, last thing, anyone know where to get a cheap crimping tool for the JST NH,RA an VL pins? Or a good relable method? I saw how Orc had paid £160 and that my friend found others for £200.

Sorry for typo's, me and Logitech are at war...

Edited by Naoki (02/10/11 02:46 AM)



----
On a quest for Digital 573 and Dancing Stage EuroMix 2

By gods I've found it!



R. Belmont
Cuckoo for IGAvania
Reged: 09/21/03
Posts: 9690
Loc: ECV-197 The Orville
Send PM


Re: Some questions regarding I/O new [Re: Naoki]
#246259 - 02/10/11 09:23 PM


> I got the JST connectors I've been waiting for today nd it got me thinking of
> controls gain. I'm a little confused how the Sga I/O Board type 1 works. After
> connecting it to a USB socket I noticed it did nothing, not even light up the LEDs.
> Fair enough, it has +12 and +5v in ports so I gathered it picks it's juice from them,
> not the USB connector.

JVS I/O boards use the same connector as USB, but the pin assignments and protocol are not at all compatible with USB. As far as I know plugging one into a real USB port (or plugging a USB device into a JVS I/O port) won't hurt anything, but it certainly won't power it up either.



Naoki
Reged: 11/10/09
Posts: 1998
Loc: United Kingdom
Send PM


Re: Some questions regarding I/O new [Re: R. Belmont]
#246262 - 02/10/11 10:12 PM


I thought not, and I know it won't work on Windows since it isn't a HID device, and I doubt it follows any standard USB protocol.

Edited by Naoki (02/10/11 10:13 PM)



----
On a quest for Digital 573 and Dancing Stage EuroMix 2

By gods I've found it!



sz72
MAME Fan
Reged: 08/20/07
Posts: 78
Send PM


Re: Some questions regarding I/O new [Re: Naoki]
#246276 - 02/11/11 12:26 AM


JVS i/o boards use the same connectors and cables used by USB devices, but everything else is different.
JVS i/o connections are basically RS422 serial lines.



Naoki
Reged: 11/10/09
Posts: 1998
Loc: United Kingdom
Send PM


Re: Some questions regarding I/O new [Re: sz72]
#246281 - 02/11/11 02:00 AM


I know that... I want to know about the specific parts on the I/O board, not that "It uses USB".



----
On a quest for Digital 573 and Dancing Stage EuroMix 2

By gods I've found it!



R. Belmont
Cuckoo for IGAvania
Reged: 09/21/03
Posts: 9690
Loc: ECV-197 The Orville
Send PM


Re: Some questions regarding I/O new [Re: Naoki]
#246329 - 02/11/11 07:32 PM


> I thought not, and I know it won't work on Windows since it isn't a HID device, and I
> doubt it follows any standard USB protocol.

Since you didn't read what I just wrote: it doesn't follow *any* USB protocol. It is not a USB device. The pin assignments are even different.



Naoki
Reged: 11/10/09
Posts: 1998
Loc: United Kingdom
Send PM


Re: Some questions regarding I/O new [Re: Naoki]
#246674 - 02/15/11 09:23 PM


Does anyone know about what I ask? If not, where should I ask? I need to know hopefully before Friday :\



----
On a quest for Digital 573 and Dancing Stage EuroMix 2

By gods I've found it!


Pages: 1

MAMEWorld >> Hardware
Previous thread Previous  View all threads Index   Next thread Next   Threaded Mode Threaded  

Extra information Permissions
Moderator:  GatKong 
0 registered and 1 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 3294