MAMEWorld >> Hardware
Previous thread Previous  View all threads Index   Next thread Next   Threaded Mode Threaded  

Pages: 1

Bigun
MAME Fan
Reged: 03/13/10
Posts: 12
Send PM


EMI Effect a MAME cabinet?
#248026 - 03/05/11 06:00 PM


For a long time, I have had trouble out of the actual computer unit in my cabinet.

I've swapped nearly everything:

- Motherboard
- Arcade VGA Card
- Processor & RAM
- Reformatted

And it STILL is showing the same symptoms:

- Random Game crashes
- Random Reboots
- Random Blue Screens
- Random program crashes

This has been going on for years.... and it is mostly unplayed because of these flaws.

And last night I had a thought.... what about EMI? My motherboard is mounted sideways and it merely 15 or so inches away from the arcade monitor with no shielding. Could this be what is causing my problems?

Edited by Bigun (03/05/11 06:34 PM)



italieAdministrator
MAME owes italie many thank yous, hah
Reged: 09/20/03
Posts: 15235
Loc: BoomTown
Send PM


Re: EMI Effect a MAME cabinet? new [Re: Bigun]
#248037 - 03/05/11 08:23 PM


I would start looking at power supply, wiring, or wall power issues before attacking the random.

I'd also make sure your heat sink is mounted tight against the cpu. Mounting some heavier heat sinks sideways can cause them to pull away from the processor a bit.


> For a long time, I have had trouble out of the actual computer unit in my cabinet.
>
> I've swapped nearly everything:
>
> - Motherboard
> - Arcade VGA Card
> - Processor & RAM
> - Reformatted
>
> And it STILL is showing the same symptoms:
>
> - Random Game crashes
> - Random Reboots
> - Random Blue Screens
> - Random program crashes
>
> This has been going on for years.... and it is mostly unplayed because of these
> flaws.
>
> And last night I had a thought.... what about EMI? My motherboard is mounted sideways
> and it merely 15 or so inches away from the arcade monitor with no shielding. Could
> this be what is causing my problems?



R. Belmont
Cuckoo for IGAvania
Reged: 09/21/03
Posts: 9690
Loc: ECV-197 The Orville
Send PM


Re: EMI Effect a MAME cabinet? new [Re: italie]
#248040 - 03/05/11 08:51 PM


I would agree - it's either cooling or power quality at that point.



krick
Get Fuzzy
Reged: 02/09/04
Posts: 4235
Send PM


Re: EMI Effect a MAME cabinet? new [Re: Bigun]
#248045 - 03/05/11 09:08 PM


How old is the motherboard? Are any of the capacitors "domed"?



GroovyMAME support forum on BYOAC



bodger319
MAME Fan
Reged: 01/23/06
Posts: 287
Send PM


Re: EMI Effect a MAME cabinet? new [Re: Bigun]
#248133 - 03/06/11 04:54 PM


One thing you do not mention as having been replaced is the PSU for the computer.

The power requirements of the new motherboard, CPU, Graphics card and RAM may be on the limits of (or even exceed) what the PSU can supply and, if it was already on the way out, replacing the other components could have made your symptoms worse.

Mark

> For a long time, I have had trouble out of the actual computer unit in my cabinet.
>
> I've swapped nearly everything:
>
> - Motherboard
> - Arcade VGA Card
> - Processor & RAM
> - Reformatted
>
> And it STILL is showing the same symptoms:
>
> - Random Game crashes
> - Random Reboots
> - Random Blue Screens
> - Random program crashes
>
> This has been going on for years.... and it is mostly unplayed because of these
> flaws.
>
> And last night I had a thought.... what about EMI? My motherboard is mounted sideways
> and it merely 15 or so inches away from the arcade monitor with no shielding. Could
> this be what is causing my problems?



FatTrucker
Randomly pressing buttons in hope of success.
Reged: 01/31/06
Posts: 917
Loc: London UK
Send PM


Re: EMI Effect a MAME cabinet? new [Re: Bigun]
#248151 - 03/06/11 06:57 PM


> For a long time, I have had trouble out of the actual computer unit in my cabinet.
>
> I've swapped nearly everything:
>
> - Motherboard
> - Arcade VGA Card
> - Processor & RAM
> - Reformatted
>
> And it STILL is showing the same symptoms:
>
> - Random Game crashes
> - Random Reboots
> - Random Blue Screens
> - Random program crashes
>
> This has been going on for years.... and it is mostly unplayed because of these
> flaws.
>
> And last night I had a thought.... what about EMI? My motherboard is mounted sideways
> and it merely 15 or so inches away from the arcade monitor with no shielding. Could
> this be what is causing my problems?

You don't mention the OS you're using either. Its almost certainly either the processor overheating (check for furring on the heatsink and that thermal paste has been used when fitting the chip). Or you have a power issue with the PSU not supplying enough juice to power all the components. Maybe related to USB devices since most PSU's will be Ok to run a PC thats only using a processor and AVGA.

The reason I mention the OS is if you're running with something non-standard like ArcadeOS, TinyXP or some other stripped down build, it could even be related to a lack of driver support for something.


Pages: 1

MAMEWorld >> Hardware
Previous thread Previous  View all threads Index   Next thread Next   Threaded Mode Threaded  

Extra information Permissions
Moderator:  GatKong 
0 registered and 1 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 2985