MAMEWorld >> Hardware
View all threads Index   Threaded Mode Threaded  

Pages: 1

LRa
MAME Fan
Reged: 09/07/05
Posts: 132
Send PM


Hyperspin screen size problem
#319572 - 01/01/14 10:26 AM Attachment: photo.jpg 24 KB (0 downloads)


Hi,
I'm trying to setup Hyperspin to work with mame and I'm having a weird problem. The screen in displayed only in the middle.
The only settings that did affect this are changing to Directdraw, which made the screen eve smaller, and GDI which made the screen full screen, but alas, GDI doesn't support HLSL.
Also, running mame with Hyperspin works fine.

ideas?

thx

[ATTACHED IMAGE]

Attachment

Edited by LRa (01/01/14 10:49 AM)



Naoki
Reged: 11/10/09
Posts: 1998
Loc: United Kingdom
Send PM


Re: Hyperspin screen size problem new [Re: LRa]
#319576 - 01/01/14 02:22 PM


> Hi,
> I'm trying to setup Hyperspin to work with mame and I'm having a weird problem. The
> screen in displayed only in the middle.
> The only settings that did affect this are changing to Directdraw, which made the
> screen eve smaller, and GDI which made the screen full screen, but alas, GDI doesn't
> support HLSL.
> Also, running mame with Hyperspin works fine.
>
> ideas?
>
> thx

Check your MAME config file if you have one, it might be related to that. Here's some of my options which works fine for me:


Code:

#
# WINDOWS VIDEO OPTIONS
#
video d3d
numscreens 1
window 1
maximize 0
keepaspect 1
unevenstretch 1
prescale 1
waitvsync 0
syncrefresh 0
menu 0

#
# DIRECTDRAW-SPECIFIC OPTIONS
#
hwstretch 1

#
# DIRECT3D-SPECIFIC OPTIONS
#
filter 0

#
# PER-WINDOW VIDEO OPTIONS
#
screen auto
aspect auto
resolution auto
view auto
screen0 auto
aspect0 auto
resolution0 auto
view0 auto
screen1 auto
aspect1 auto
resolution1 auto
view1 auto
screen2 auto
aspect2 auto
resolution2 auto
view2 auto
screen3 auto
aspect3 auto
resolution3 auto
view3 auto

#
# FULL SCREEN OPTIONS
#
triplebuffer 0
switchres 0
full_screen_brightness 1.0
full_screen_contrast 1.0
full_screen_gamma 1.0




----
On a quest for Digital 573 and Dancing Stage EuroMix 2

By gods I've found it!



LRa
MAME Fan
Reged: 09/07/05
Posts: 132
Send PM


Solved. But screen brightness problem new [Re: Naoki]
#319577 - 01/01/14 02:29 PM


Ok. I managed to solve this. thx.

But for some reason, when using HLSL with mame .152, the screen is a lot brighter compared to the other version I user of mame .148. The mame.ini are the same.
Any ideas why?

p.s. also the scanlines are showing less.

Edited by LRa (01/01/14 03:52 PM)



B2K24
MAME @ 15 kHz Sony Trinitron CRT user
Reged: 10/25/10
Posts: 2650
Send PM


Re: Solved. But screen brightness problem new [Re: LRa]
#319601 - 01/01/14 11:26 PM


raster_bloom_scale makes things very bright so you might need to decrease that value



LRa
MAME Fan
Reged: 09/07/05
Posts: 132
Send PM


PERFECT! new [Re: B2K24]
#319602 - 01/02/14 12:47 AM


Many many thanks.

Setting it to 0.15 gives the old look back.


Pages: 1

MAMEWorld >> Hardware
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  GatKong 
0 registered and 2 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 3739