MAMEWorld >> EmuChat
View all threads Index   Threaded Mode Threaded  

Pages: 1

Galaxian
Lurker
Reged: 09/21/03
Posts: 132
Send PM


Mame 0.155 Compile error using new tools
#333434 - 10/18/14 08:19 AM


Hi

I've done a clean install of the new tools at http://www.mamedev.org/tools/
But getting the following error right at the end:

Generating H8-300 source file...
process_begin: CreateProcess(NULL, python src/emu/cpu/h8/h8make.py src/emu/cpu/h8/h8.lst o obj/windows64/emu/cpu/h8/h8.inc, ...) failed.
src/emu/cpu/cpu.mak:650: recipe for target 'obj/windows64/emu/cpu/h8/h8.inc' failed
make (e=2): The system cannot find the file specified.
make: *** [obj/windows64/emu/cpu/h8/h8.inc] Error 2
make: *** Waiting for unfinished jobs....
Finished!
0 Hours 30 Minutes and 44 Seconds Elapsed.

I've already run ;setup-qt.bat and setenv.bat

Thanks in advance.



mahlemiut
MAME Fan
Reged: 06/19/07
Posts: 56
Loc: New Zealand
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: Galaxian]
#333435 - 10/18/14 08:34 AM


> Hi
>
> I've done a clean install of the new tools at http://www.mamedev.org/tools/
> But getting the following error right at the end:
>
> Generating H8-300 source file...
> process_begin: CreateProcess(NULL, python src/emu/cpu/h8/h8make.py
> src/emu/cpu/h8/h8.lst o obj/windows64/emu/cpu/h8/h8.inc, ...) failed.
> src/emu/cpu/cpu.mak recipe for target 'obj/windows64/emu/cpu/h8/h8.inc' failed
> make (e=2): The system cannot find the file specified.
> make: *** [obj/windows64/emu/cpu/h8/h8.inc] Error 2
> make: *** Waiting for unfinished jobs....
> Finished!
> 0 Hours 30 Minutes and 44 Seconds Elapsed.
>
> I've already run ;setup-qt.bat and setenv.bat
>
> Thanks in advance.

Did you run setup-Python.bat also?



- Barry Rodewald
Editor at MARP - http://replay.marpirc.net



Galaxian
Lurker
Reged: 09/21/03
Posts: 132
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: mahlemiut]
#333440 - 10/18/14 09:36 AM


Do the bat files need to be run in a particular order?



Hadou Ken
MAME Fan
Reged: 10/07/06
Posts: 53
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: Galaxian]
#333442 - 10/18/14 10:26 AM


Would this work for you in a .bat file?

set MINGW_ROOT=..\mingw\mingw64-w64
set PATH=%MINGW_ROOT%\bin;%MINGW_ROOT%\opt\bin;%MINGW_ROOT%\Qt\bin;%PATH%

gcc -v

make

pause



lamprey
MAME Fan
Reged: 12/01/11
Posts: 238
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: Galaxian]
#333452 - 10/18/14 02:12 PM


Hadou Ken's solution should work for you, but I'll also post mine incase it helps.

I have my two directories as:
c:\mamesrc
c:\mingw

I launch a command prompt from the mamesrc directory using the cmd.dat file that comes with the compile_extras.zip.

Then I run the MakeMame.bat. This came from the compile extras also, but I changed it slightly. Here is the text of the bat file:
Code:

set path=c:\mingw\mingw64-w64\bin;c:\mingw\mingw64-w64\opt\bin;c:\mingw\mingw64-w64\Qt\bin;%PATH%

make -j5

And if you want an SDL build:
Code:

set path=c:\mingw\mingw64-w64\bin;c:\mingw\mingw64-w64\opt\bin;c:\mingw\mingw64-w64\Qt\bin;%PATH%

make -j5 TARGETOS=win32 TARGET=mame OSD=sdl PTR64=1 NOWERROR=1


Cheers!



Galaxian
Lurker
Reged: 09/21/03
Posts: 132
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: lamprey]
#333454 - 10/18/14 04:30 PM


Thanks to both for your help.

One thing is confusing me.the 'easy way' instructions at Mamedev.org state that only setup-qt.bat needs to be run; should all three bat files be run, if so in what order?

Cheers



lamprey
MAME Fan
Reged: 12/01/11
Posts: 238
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: Galaxian]
#333455 - 10/18/14 04:43 PM


I don't spend enough time compiling MAME to really know about the bat file order. But, I found that I don't need to run them if I use the paths as I described above.



Andypc
Andypc
Reged: 10/27/07
Posts: 38
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: lamprey]
#333503 - 10/19/14 12:31 PM


I am having the exactly the same problem. Never had a problem compiling before. Run the setup-Python.bat, but still got the same error.

I am trying to compile both a 64bit and 32bit version of Mame 0.155 with the "hiscore diff (with no nag/white box removal)"

I am getting a compile error:-

Make.exe: *** [obj/windows64/emu/cpu/h8/h8.inc] Error 2

I downloaded latest Mingw and Source from Mamedev.org and the 155 Hiscore diff.

The command I used for the 64bit version was:-

make.exe -j3 ARCHOPTS=-march=core2 PTR64=1



Anonymous
Unregistered
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: Andypc]
#333509 - 10/19/14 06:47 PM


> I am having the exactly the same problem. Never had a problem compiling before. Run
> the setup-Python.bat, but still got the same error.

The new tools need a new entry in PATH, which I'm sure was documented on mamedev.org when I last looked.



Master O
Yes, Even Parodius Music
Reged: 11/20/06
Posts: 1283
Send PM


Re: Mame 0.155 Compile error using new tools new [Re: ]
#333918 - 10/28/14 04:03 PM


> > I am having the exactly the same problem. Never had a problem compiling before. Run
> > the setup-Python.bat, but still got the same error.
>
> The new tools need a new entry in PATH, which I'm sure was documented on mamedev.org
> when I last looked.

If you're talking about this page:

http://www.mamedev.org/tools/

There is no mention of setup-python.bat anywhere there.



"Note to Noobs:

We are glad to help you but simply posting that something does not work is not going to lead to you getting help. The more information you can supply defining your problem, the less likely it will be that you will get smart-alec replies.

C.D.~"


Pages: 1

MAMEWorld >> EmuChat
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  redk9258, URherenow, Tafoid 
0 registered and 2 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 4261