MAMEWorld >> Hardware
View all threads Index   Threaded Mode Threaded  

Pages: 1

VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Hardware or software issue?
#336418 - 01/27/15 01:08 PM


I am using a JPAC connected to the JAMMA connector.

3 controllers, 2 buttons per player, 3 buttons that are player select buttons.

Within MAME, I hit TAB and try to get the third joystick to register, everything clicks just fine even the buttons with no visible (to me) issues. Program does not detect any input.

Player one joystick and player two joystick and the two buttons work automatically.

One strange issue: On many games player one button one appears to do one tap or punch upon start of many games. Also, on some games it seems to be doing some strange things, like in Gun.Smoke if I hit player one button one once to shoot left, it will fire and then enter a loop of firing!!!?????!?

Button itself mechanically does not seem to have a major issue or feel like it is sticking. and, in many cases if it was sticking it should be shooting constantly, but in other games it does not. Like Combatribes, it only does that first punch. But in WILLOW it seems to skip the cut scenes due to apparent button activation I am guessing.

Also, in Gun.Smoke I tried to get the left button shooting left, the right button shooting right and both pressed at same time do button 3 for shooting ahead and it NEVER shoots right just ahead and left.

The player select buttons also don't seem to register at all either within TAB and binding keys.

I can live without the third joystick and buttons, but I really want to figure out what exactly is going on with the button working with gun.Smoke not letting me shoot right even when binded and why it enters a shoot left loop from player one button one when I cannot see any visual issues. YET, in other games like COMBATRIBES I only have the first extra punch and then it's fine, no looping. WHAT THE HECK IS GOING ON HERE!@!!!!!!!?????? I can't sense a consistency to this to troubleshoot!



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336419 - 01/27/15 01:36 PM


I remapped all player one buttons to the player two buttons and ruled it out: It's a hardware issue. I just wish I could tell visually what is so wrong with the button. I just can't tell!



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336420 - 01/27/15 01:37 PM


But why doesn't player three joystick / controls register? Does JAMMA connector not support 3 players?



bodger319
MAME Fan
Reged: 01/23/06
Posts: 287
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336437 - 01/27/15 08:33 PM


> But why doesn't player three joystick / controls register? Does JAMMA connector not
> support 3 players?

You got it in one. Just google JAMMA.
It supports 2 players. As yours was a 3 player cab, the relevant connections for the 3rd player controls is/was probably a seperate plug on to the PCB. Just trace the wiring from those controls and see where they go.

As to your other symptoms, I am wondering whether it is not a sticky switch causing it but rather a sloppy one resulting in switch-bounce and in certain games triggering a double-tap condition.
ie when you press the button, the switch, rather than changing from off to on, is actually going off-on-off-on (repeat off-on for number of switch bounces) and the game is then registering it as the button being pressed rapidly in quick succession and reacting accordingly.



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: bodger319]
#336506 - 01/29/15 11:17 AM


Since the third players buttons are currently not being used I swapped out the player three punch button + switch with the player one button + switch. Shockingly... the issue still exists even with a different switch / button.

I find it hard to believe both buttons would have the same exact fail...

I also find it hard to believe it's the wiring since the buttons and switches appear to be functioning other than the extra crap going on more noticeably in certain games.

Any ideas?

Also, is it possible to manually wire my other joystick and buttons onto the J-pac? I see it has switches on it but I am still learning here, so please bare with me and help me out.



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336507 - 01/29/15 11:21 AM


wait a moment! I see that the punch button wire tethers to the joystick right button switch. I did not realize this. The issue may be the joystick switch? I'll swap that out next.



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336508 - 01/29/15 11:30 AM


Oh My GOD! I FIXED IT. I noticed the one wire wasn't connected the same way the other buttons were and now it works perfectly.

This means the arcade machine came to me with the player 1 punch button hooked up incorrectly! This was not my doing! WIERD!!!!



Bad A Billy
Oop Ack!
Reged: 12/27/07
Posts: 1007
Loc: Outland
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336517 - 01/29/15 04:40 PM


I was going to suggest making sure that the buttons were grounded properly. Sounds like you figured it out though. You should see what some people do to their machines and then wonder why they don't work. I found 1 machine where they had looped all the grounds together, no actual ground mind you, just a big loop and guess what? None of the controls would work! Huh? Amazing...

Game On!



Pessimist: Oh, this can't get any worse!
Optimist: Yes, it can!



bodger319
MAME Fan
Reged: 01/23/06
Posts: 287
Send PM


Re: Hardware or software issue? new [Re: VGCodeMaster]
#336537 - 01/30/15 12:50 AM


> Also, is it possible to manually wire my other joystick and buttons onto the J-pac? I
> see it has switches on it but I am still learning here, so please bare with me and
> help me out.

The extra connections on the J-PAC are to add extra buttons to Player 1 and Player 2.
To add controls for a third player, one option is to add an I-PAC.
http://www.ultimarc.com/jpac2.html



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: bodger319]
#336548 - 01/30/15 10:15 AM


My next project is obvious then: inspect my cables and the JPAC and manually wire the 3 player select buttons to the JPAC so I can either use them as a third button OR to select players.

Is there a switch on the JPAC for a coin switch? I am guessing there is. I need to look and see how this works. I see the switches are labeled like switch 1 switch 2 on the JPAC but not sure which ones to use. I am guessing I can find that out my looking for a diagram on the site though.



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: Hardware or software issue? new [Re: Bad A Billy]
#336549 - 01/30/15 11:21 AM


From Ultimarc: What controls does the JAMMA connector support?

The JAMMA standard supports 2 players with 3 buttons per player. There is an unofficial addition to this, some cabinets wire a fourth button. Plus coin, start etc.

-----

Now this has me truly confused. My player select buttons SHOULD be supported then....

I followed the two yellow and one gray wire from the player select buttons and they lead into the JAMMA cable directly. However, I receive no response from pressing these buttons in MAME whatsoever. (unmappable, no detection.)

Any ideas?

EDIT EDIT UPDATE UDATE!!!!!!

I DID IT!!!!! I MANUALLY SLICED the wires and connected just the ground and the one wire and since the three buttons are chained together ALL THREE worked!

At first player one sent 2 and player 2 sent a 1 and the player 3 button sends a Z

I swapped the connectors to make button one actually send 1 and button 2 actually send 2.

So since I only have 2 players I have one extra button for the time being until I buy an IPAC or something.... So... I guess I can slap a dollar sign on the third button and call it the coin button and map Z for coins.

Sounds like a plan?

I know you guys prolly think this is silly but I AM PROUD OF MYSELF. I am new to this stuff and have NO one here with me yet I was able to slice all the dumb plastic ties to get a good look at where each wire was going to figure out which ones I really needed.

Seriously.

Can't believe I did it.



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


New Issue Confused new [Re: VGCodeMaster]
#336552 - 01/30/15 12:38 PM


So when I hit player 1 and player 2 start buttons SIMULTANEOUSLY

(which both do keyboard strokes 1 and 2)

MAME crashes sometimes. Not sure why this would happen... any ideas?

This is a pretty serious issue as it's not that uncommon to both die and smack the buttons in the heat of the moment to get back into the game...

The third button, player 3 which sends a Z, and any combo of the other two with this button never cause a crash.

Is it an issue with how they are chained together? Should I get some extra wires and try to run each button seperately onto the J PAC? is that the problem that they are chained together?



bodger319
MAME Fan
Reged: 01/23/06
Posts: 287
Send PM


Re: New Issue Confused new [Re: VGCodeMaster]
#336557 - 01/30/15 06:03 PM


> So when I hit player 1 and player 2 start buttons SIMULTANEOUSLY
>
> (which both do keyboard strokes 1 and 2)
>
> MAME crashes sometimes. Not sure why this would happen... any ideas?

Have a look at the Default Key code table on the page I linked to before.
P1 Start is used as a Shift Key. When pressed together with the P2 Start button it sends the esc character to the computer.

Regards
Bodger319



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: New Issue Confused new [Re: bodger319]
#336558 - 01/30/15 10:10 PM


How do I fix it though?



bodger319
MAME Fan
Reged: 01/23/06
Posts: 287
Send PM


Re: New Issue Confused new [Re: VGCodeMaster]
#336572 - 01/31/15 02:48 PM


> How do I fix it though?

With all respect.
Try reading through the page that I gave you the link to.
RTFM generally helps.

Regards.



VGCodeMaster
MAME Fan
Reged: 01/22/15
Posts: 20
Send PM


Re: New Issue Confused new [Re: bodger319]
#336574 - 01/31/15 05:12 PM


I fixed it by changing the MAME controls to CTRL + Escape to exit the UI.

This has the added benefit of making sure I don't press escape and exit games by accident.

I read the link you gave me, I did not see a solution to the issue I am having. I am asking for help, forums are a major place for getting help ( or helping ).

I am not happy with your response to me at all. I find it a bit rude.

If you follow the whole posting, you will see that even though I came here for help, I fixed all of my own problems.

I do not deserve to receive an unhelpful attitude from anyone. If you don't wish to help further, please refrain from posting.


Pages: 1

MAMEWorld >> Hardware
View all threads Index   Threaded Mode Threaded  

Extra information Permissions
Moderator:  GatKong 
0 registered and 1 anonymous users are browsing this forum.
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled
Thread views: 2758